$re = '/^[^|]*\|[^|]*$/m';
$str = '234da|1245 - эту надо найти
rwewef|1234123|2f23 - эту не надо';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);