re = /^[^|]*\|[^|]*$/m
str = '234da|1245 - эту надо найти
rwewef|1234123|2f23 - эту не надо'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end