$re = '/(\[\w+\][^[]+)(\[\w+\][^[]+)/m';
$str = 'someaddres.com/?f=[B]a-test,a test,Test[C]test a,test2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);