re = /(\[\w+\][^[]+)(\[\w+\][^[]+)/m
str = 'someaddres.com/?f=[B]a-test,a test,Test[C]test a,test2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end