using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"abc\d+_def(\d{2})";
string input = @"abc1_def23
abc10_def99
abc9_def9";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}