package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`abc\d+_def(\d{2})`)
var str = `abc1_def23
abc10_def99
abc9_def9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}