$re = '/(?<=\d)(?=(?:\d\d\d)+$)/m';
$str = '112345678
';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;