import re
regex = re.compile(r"(?<=\d)(?=(?:\d\d\d)+$)", flags=re.MULTILINE)
test_str = ("112345678\n")
subst = ","
result = regex.sub(subst, test_str)
if result:
print(result)