$re = '/[a-zA-Z][/]u[/](?!.*-$)[a-zA-Z0-9-_]+\b$/m';
$str = 'a/u/some-name-
a/u/some-name
a/u/-some-name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);