re = /[a-zA-Z][\/]u[\/](?!.*-$)[a-zA-Z0-9-_]+\b$/m
str = 'a/u/some-name-
a/u/some-name
a/u/-some-name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end