import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{4}\\-[0-9]{2}-[0-9]{2} app\\[[a-zA-Z0-9.]+\\]\\: [0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}$";
final String string = "2014-08-26 app[web.1]: 50.0.134.125\n"
+ "something not accurate\n"
+ "@!#$ saf 123\n"
+ "saasfd asdf asf asdf asdf asdf ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}