$re = '/^[0-9]{4}\-[0-9]{2}-[0-9]{2} app\[[a-zA-Z0-9.]+\]\: [0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}$/m';
$str = '2014-08-26 app[web.1]: 50.0.134.125
something not accurate
@!#$ saf 123
saasfd asdf asf asdf asdf asdf ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);