package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(\d{0,2})-)?(?:(\d{0,2}):)?(\d{0,2}\.?\d*)`)
var str = `1:42.15 (1)
19.78 (1)
2-24:04
8:03.280 (1)
1:42.15 (1)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}