// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(\d{0,2})-)?(?:(\d{0,2}):)?(\d{0,2}\.?\d*)").unwrap();
let string = "1:42.15 (1)
19.78 (1)
2-24:04
8:03.280 (1)
1:42.15 (1)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}