#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\d{4,}|\d{1,3}(?:,\d{3})*)(?:\.\d+)?"
Local $sString = "the number is 1000 today" & @CRLF & _
"the number is 1000.00 today" & @CRLF & _
"the number is 1000.142 today" & @CRLF & _
"the number is 1000.30 today" & @CRLF & _
"the number is 1000.200 today" & @CRLF & _
"the number is 1,000 today" & @CRLF & _
"the number is 1,000.00 today" & @CRLF & _
"the number is 1,000.142 today" & @CRLF & _
"the number is 1,000.30 today" & @CRLF & _
"the number is 1,000.200 today"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")