import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\d{4,}|\\d{1,3}(?:,\\d{3})*)(?:\\.\\d+)?";
final String string = "the number is 1000 today\n"
+ "the number is 1000.00 today\n"
+ "the number is 1000.142 today\n"
+ "the number is 1000.30 today\n"
+ "the number is 1000.200 today\n"
+ "the number is 1,000 today\n"
+ "the number is 1,000.00 today\n"
+ "the number is 1,000.142 today\n"
+ "the number is 1,000.30 today\n"
+ "the number is 1,000.200 today";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}