const regex = /^([a-z0-9]+(?:([_-]+|[.])[\w-]+|[_-])*)@([a-z0-9]+(?:([.-]\w+)*\.)[a-z]{2,13})$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z0-9]+(?:([_-]+|[.])[\\w-]+|[_-])*)@([a-z0-9]+(?:([.-]\\w+)*\\.)[a-z]{2,13})$', 'i')
const str = `tetes-.-.test.s@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}