$re = '/^([a-z0-9]+(?:([_-]+|[.])[\w-]+|[_-])*)@([a-z0-9]+(?:([.-]\w+)*\.)[a-z]{2,13})$/i';
$str = 'tetes-.-.test.s@gmail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);