package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})(?:\:(\d{1,5}))?`)
var str = `[<Device: 192.168.222.123:8075>]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}