re = /(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})(?:\:(\d{1,5}))?/
str = '[<Device: 192.168.222.123:8075>]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end