package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\w-]+)\s*:\s*([^;]+)\s*;?`)
var str = `text-align:center; float:left;width:18%;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}