$re = '/([\w-]+)\s*:\s*([^;]+)\s*;?/m';
$str = 'text-align:center; float:left;width:18%;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);