import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^>\n"
+ "(?P<header>\n"
+ "[^\\n()]*\n"
+ " (?:\\((?P<name>[^\\n()]+)\\))?\n"
+ "[^()\\n]*\n"
+ ")\n"
+ "[\\n\\r]\n"
+ "(?P<content>[\\s\\S]+?)(?=^>|\\Z)";
final String string = ">XM_024446048.1 PREDICTED: Homo sapiens mannosidase alpha class 2A member 1 (MAN2A1), transcript variant X2, mRNA\n"
+ "CAGCCCCC\n"
+ "TGAGCGAC\n"
+ "TCCCTAATGTG\n"
+ "ACAGTAAAGAA\n"
+ ">NM_001308028.1 Homo sapiens FER tyrosine kinase (FER), transcript variant 2, mRNA\n"
+ "CAGCCC\n"
+ "CCGTGACGC\n"
+ "GGGGTGGTGACT\n"
+ "GGCTC\n"
+ "GGTGGT\n"
+ "GTGAC\n"
+ ">NM_0013082323028.1 H STZ mRSN1A\n"
+ "CAGCCC\n"
+ "CCGTGACGC\n"
+ "GGG\n"
+ "GTGGTGA\n"
+ "CTGGCTCCGGAGT\n"
+ "CTGAGGGGTTCGG";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}