# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^>
(?P<header>
[^\n()]*
(?:\((?P<name>[^\n()]+)\))?
[^()\n]*
)
[\n\r]
(?P<content>[\s\S]+?)(?=^>|\Z)
"""
test_str = (">XM_024446048.1 PREDICTED: Homo sapiens mannosidase alpha class 2A member 1 (MAN2A1), transcript variant X2, mRNA\n"
"CAGCCCCC\n"
"TGAGCGAC\n"
"TCCCTAATGTG\n"
"ACAGTAAAGAA\n"
">NM_001308028.1 Homo sapiens FER tyrosine kinase (FER), transcript variant 2, mRNA\n"
"CAGCCC\n"
"CCGTGACGC\n"
"GGGGTGGTGACT\n"
"GGCTC\n"
"GGTGGT\n"
"GTGAC\n"
">NM_0013082323028.1 H STZ mRSN1A\n"
"CAGCCC\n"
"CCGTGACGC\n"
"GGG\n"
"GTGGTGA\n"
"CTGGCTCCGGAGT\n"
"CTGAGGGGTTCGG")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.