import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "</?(EMPTY|[bui]|sup|sub|strong|strike|small|ul|ol|li|a|em|br\\s*/?|img|var|span|div|p|run\\d|style|center)(\\s+[^<>]+)??>|^((PA|Q)\\d[A-Z0-9]+)$|<br\\s?/>|[▼►⇑●]|&#x\\w+?;|%s|(\\{#.+?\\}|\\{@.*?\\}|\\{[A-Z_]+\\}|\\[(?!COUNTRY)[A-Z_]{2,}\\]|\\^\\w+\\$|</?g\\d+>)|(?<eqls>\\[(INCENTIVE TYPE/AMOUNT|Email address)\\])";
final String string = "[COUNTRY]\n"
+ "[country]\n"
+ "[Country]\n"
+ "[foobar]\n"
+ "[FOOBAR]\n"
+ "[INCENTIVE TYPE/AMOUNT]\n"
+ "[Email address]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}