const regex = new RegExp('</?(EMPTY|[bui]|sup|sub|strong|strike|small|ul|ol|li|a|em|br\\s*/?|img|var|span|div|p|run\\d|style|center)(\\s+[^<>]+)??>|^((PA|Q)\\d[A-Z0-9]+)$|<br\\s?/>|[▼►⇑●]|&#x\\w+?;|%s|(\\{#.+?\\}|\\{@.*?\\}|\\{[A-Z_]+\\}|\\[(?!COUNTRY)[A-Z_]{2,}\\]|\\^\\w+\\$|</?g\\d+>)|(?<eqls>\\[(INCENTIVE TYPE/AMOUNT|Email address)\\])', 'gm')
const str = `[COUNTRY]
[country]
[Country]
[foobar]
[FOOBAR]
[INCENTIVE TYPE/AMOUNT]
[Email address]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}