$re = '/(\d)(?=(\d{3})+(?:(\.)\d+)?$)/m';
$str = '11301212121.00020012121
11301212121
113012121';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);