re = /(\d)(?=(\d{3})+(?:(\.)\d+)?$)/m
str = '11301212121.00020012121
11301212121
113012121'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end