package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^\s*(')([^'\\]*(?:\\.[^'\\]*)*)(')`)
var str = `'Hello World'
'There\'s an apostrophe in here'
'This is a backslash: \\'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}