re = /^\s*(')([^'\\]*(?:\\.[^'\\]*)*)(')/m
str = '\'Hello World\'
\'There\\\'s an apostrophe in here\'
\'This is a backslash: \\\\\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end