#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)\.(.*?)(?=\d)(.*)$"
Local $sString = "612. Grt. Am. Mgt. & Inv. 7.33" & @CRLF & _
"77. Wickes 4.61" & @CRLF & _
"265. Wang Labs 8.75" & @CRLF & _
"9. CrossLand Savings 6.32" & @CRLF & _
"228. JPS Textile Group 2.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")