re = /^(.*?)\.(.*?)(?=\d)(.*)$/m
str = '612. Grt. Am. Mgt. & Inv. 7.33
77. Wickes 4.61
265. Wang Labs 8.75
9. CrossLand Savings 6.32
228. JPS Textile Group 2.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end