import re
regex = re.compile(r"(?:^|(?<=.(?:[\s])))([л]+[\s-]*[о]+[\s-]*[х]+)+(?:$|[\s-])", flags=re.MULTILINE | re.IGNORECASE | re.UNICODE)
test_str = ("лох плох ппп лох лоох ллох л о х \n"
"лох\n"
"плох\n"
"ппп\n"
"лох\n"
"лоох\n"
"ллох лох лохло х лохло хлам\n"
"л о х\n"
"л оо х\n"
"лоох\n"
"лox\n"
"лооx\n"
"лооох\n"
"плохо\n"
"неплохо\n"
"лохотрон\n"
"блоха\n"
"заглох \n"
"он оглох от взыва\n"
"он лоооох меня\n"
"он л-ох меня\n"
"он лОх меня\n"
"тыЛОХчего\n"
"металлохимия\n"
"маслохранилище\n"
"мой лохматый друг\n"
"лох")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")