import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?:^|(?<=.(?:[\s])))([л]+[\s-]*[о]+[\s-]*[х]+)+(?:$|[\s-])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
лох плох ппп лох лоох ллох л о х
лох
плох
ппп
лох
лоох
ллох лох лохло х лохло хлам
л о х
л оо х
лоох
лox
лооx
лооох
плохо
неплохо
лохотрон
блоха
заглох
он оглох от взыва
он лоооох меня
он л-ох меня
он лОх меня
тыЛОХчего
металлохимия
маслохранилище
мой лохматый друг
лох
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)