using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""i\"":\""https:\/\/[^\""]+?\/";
string input = @"""i"":""https://mylink.com/2634/2634441_200x200.jpg"",""l";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}