$re = '/\"i\":\"https:\/\/[^\"]+?\//';
$str = '"i":"https://mylink.com/2634/2634441_200x200.jpg","l';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);