const regex = new RegExp('(.*?)-host1\\.host2\\.host3\\.com:80', '')
const str = `my-name-host1.host2.host3.com:80`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}