$re = '`(.*?)-host1\.host2\.host3\.com:80`';
$str = 'my-name-host1.host2.host3.com:80';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);