#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)@if\((.*?)\)\s+{{\s*(.*)\s*}}"
Local $sString = "" & @CRLF & _
"@if(topLevel)" & @CRLF & _
"{{" & @CRLF & _
" <form method="post">" & @CRLF & _
" @if(bottomLevel)" & @CRLF & _
" {{" & @CRLF & _
" <input>" & @CRLF & _
" }}" & @CRLF & _
" </form>" & @CRLF & _
"}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")