using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@if\((.*?)\)\s+{{\s*(.*)\s*}}";
string input = @"
@if(topLevel)
{{
<form method=""post"">
@if(bottomLevel)
{{
<input>
}}
</form>
}}";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}