const regex = /(\^)(\w)(\^)(\w)(\s)(\w)(\s)(\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\^)(\\w)(\\^)(\\w)(\\s)(\\w)(\\s)(\\w)', 'gm')
const str = `FICTIEF&&FICTIEF^J^A B C^^^^L^^^^NL1~FICTIEF&&FICTIEF^JAN^^^^^N^^^^NL1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}