$re = '/(\^)(\w)(\^)(\w)(\s)(\w)(\s)(\w)/m';
$str = 'FICTIEF&&FICTIEF^J^A B C^^^^L^^^^NL1~FICTIEF&&FICTIEF^JAN^^^^^N^^^^NL1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);