re = /((https?|ftp):\/\/(?:www\.|(?!www))[^\s.]+\.\S{2,}|www\.\S+\.\S{2,})/
str = 'Look at http://www.google.com some more text here possibly
Look at https://www.google.com some more text here possibly
Look at ftp://www.google.com some more text here possibly
Look at http://google.com some more text here possibly
Look at www.google.com some more text here possibly'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end