import Foundation
let pattern = #"((https?|ftp)://(?:www\.|(?!www))[^\s.]+\.\S{2,}|www\.\S+\.\S{2,})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Look at http://www.google.com some more text here possibly
Look at https://www.google.com some more text here possibly
Look at ftp://www.google.com some more text here possibly
Look at http://google.com some more text here possibly
Look at www.google.com some more text here possibly
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)