#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^# .*⤵(?:\n(?!# ).*)*)\n(^## .*)\n(?!#+ )(.*(?:\n(?!#).*)*)"
Local $sString = "# Heading 1 ⤵" & @CRLF & _
"## Heading 1.1" & @CRLF & _
"Text of Heading 1.1" & @CRLF & _
"Text can span over multiple lines" & @CRLF & _
"Even more text" & @CRLF & _
"## Heading 1.2 " & @CRLF & _
"Text of Heading 1.2" & @CRLF & _
"# Heading 2" & @CRLF & _
"## Heading 2.1" & @CRLF & _
"Text of Heading 2.1" & @CRLF & _
"## Heading 2.2" & @CRLF & _
"Text of Heading 2.2" & @CRLF & _
"# Heading 3 ⤵" & @CRLF & _
"## Heading 3.1" & @CRLF & _
"Text of Heading 3.1" & @CRLF & _
"## Heading 3.2" & @CRLF & _
"Text of Heading 3.2" & @CRLF & _
"# Heading 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")