import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^# .*⤵(?:\\n(?!# ).*)*)\\n(^## .*)\\n(?!#+ )(.*(?:\\n(?!#).*)*)";
final String string = "# Heading 1 ⤵\n"
+ "## Heading 1.1\n"
+ "Text of Heading 1.1\n"
+ "Text can span over multiple lines\n"
+ "Even more text\n"
+ "## Heading 1.2 \n"
+ "Text of Heading 1.2\n"
+ "# Heading 2\n"
+ "## Heading 2.1\n"
+ "Text of Heading 2.1\n"
+ "## Heading 2.2\n"
+ "Text of Heading 2.2\n"
+ "# Heading 3 ⤵\n"
+ "## Heading 3.1\n"
+ "Text of Heading 3.1\n"
+ "## Heading 3.2\n"
+ "Text of Heading 3.2\n"
+ "# Heading 4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}