import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{2}\\.[3].+$";
final String string = "26.3730004 \n"
+ "27.0210000 \n"
+ "26.3730009 \n"
+ "26.7114001 \n"
+ "23.9610071 \n"
+ "26.0A34430 \n"
+ "23.3670005 \n"
+ "26.0B05430 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}