package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:40[0-9][0-5]|[1-3][0-9]{3}|[0-9]{1,3}),(?:40[0-9][0-5]|[1-3][0-9]{3}|[0-9]{1,3}),(?:40[0-9][0-5]|[1-3][0-9]{3}|[0-9]{1,3}),(?:40[0-9][0-5]|[1-3][0-9]{3}|[0-9]{1,3})$`)
var str = `1200,2500,6500,90
1200,2500,6500,90
1200,2500,4095,90
0,0,0,0
4095,4095,4095,4095
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}