$re = '/^(?:40[0-9][0-5]|[1-3][0-9]{3}|[0-9]{1,3}),(?:40[0-9][0-5]|[1-3][0-9]{3}|[0-9]{1,3}),(?:40[0-9][0-5]|[1-3][0-9]{3}|[0-9]{1,3}),(?:40[0-9][0-5]|[1-3][0-9]{3}|[0-9]{1,3})$/m';
$str = '1200,2500,6500,90
1200,2500,6500,90
1200,2500,4095,90
0,0,0,0
4095,4095,4095,4095
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);