#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]|1[0-2])$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4" & @CRLF & _
"5" & @CRLF & _
"6" & @CRLF & _
"7" & @CRLF & _
"8" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"12" & @CRLF & _
"13"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")